CVEvulnerability

CVE-2026-49877

8.1 HIGH Published 2026-06-30 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-30
Last modified
2026-10-25
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-285

Description

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Affected configurations

• apache activemq (< 5.19.8) • apache activemq (>= 6.0.0 < 6.2.7)

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References