CVEvulnerability
CVE-2026-50016
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-25
- Last modified
- 2026-06-29
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-23
Description
pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm allows a transitive dependency alias from registry package metadata to contain path traversal segments. During install, pnpm later uses that alias as a filesystem path when linking dependency nodes. As a result, a registry package can cause `pnpm install --ignore-scripts` to replace paths in the current project with symlinks to attacker-controlled dependency package directories. This vulnerability is fixed in 10.34.0 and 11.4.0.
Affected configurations
• pnpm pnpm (< 10.34.0)
• pnpm pnpm (>= 11.0.0 < 11.4.0)
Related
Weakness · CWE (1)
- CWE-23 Relative Path Traversal weakness
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-hwx4-2j3j-g496 Exploit, Vendor Advisory
- https://github.com/pnpm/pnpm/security/advisories/GHSA-hwx4-2j3j-g496 Exploit, Vendor Advisory