CVEvulnerability
CVE-2026-52860
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-06-11
- Last modified
- 2026-09-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.5 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.0 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Vim is an open source, command line text editor. Prior to version 9.2.0597, Vim's Python omni-completion executes reconstructed function and class definitions from the current buffer with exec() as part of populating the completion dictionary. Python evaluates function default values, parameter annotations, and class base expressions at definition time, so a hostile buffer can execute attacker-controlled Python expressions during omni-completion. The existing g:pythoncomplete_allow_import mitigation (GHSA-52mc-rq6p-rc7c) does not cover this path, because the attacker-controlled code is not a harvested import/from statement. This issue has been patched in version 9.2.0597.
Affected configurations
• vim vim (< 9.2.0597)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/vim/vim/commit/c8c63673bc4253212820626aeeb75999d9a539d2 Patch
- https://github.com/vim/vim/releases/tag/v9.2.0597 Product
- https://github.com/vim/vim/security/advisories/GHSA-52mc-rq6p-rc7c Mitigation, Vendor Advisory
- https://github.com/vim/vim/security/advisories/GHSA-65p9-mwwx-7468 Vendor Advisory
- https://access.redhat.com/security/cve/CVE-2026-52860 access.redhat.com
- https://bugzilla.redhat.com/show_bug.cgi?id=2487987 bugzilla.redhat.com
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52860.json security.access.redhat.com