CVEvulnerability

CVE-2026-53404

7.3 HIGH Published 2026-06-29 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-29
Last modified
2026-10-25
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-670

Description

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Affected configurations

• apache tomcat (>= 8.5.0 <= 8.5.100) • apache tomcat (>= 9.0.0 < 9.0.119) • apache tomcat (>= 10.1.0 < 10.1.56) • apache tomcat (>= 11.0.0 < 11.0.23)

Related

Weakness · CWE (1)

  • CWE-670 Always-Incorrect Control Flow Implementation weakness

References