CVEvulnerability

CVE-2026-53421

9.8 CRITICAL Published 2026-07-20 Modified 2026-10-24 Official page ↗
Status
Analyzed
Published
2026-07-20
Last modified
2026-10-24
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-653

Description

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve remote code execution through the connector subsystem by relying on scripted connectors' (REST and SQL) capability to run Groovy scripts. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by hardening the Groovy security sandbox.

Affected configurations

• apache syncope (>= 3.0.0 <= 3.0.16) • apache syncope (>= 4.0.0 < 4.0.7) • apache syncope (>= 4.1.0 < 4.1.2)

Related

Weakness · CWE (1)

  • CWE-653 Improper Isolation or Compartmentalization weakness

References