CVEvulnerability
CVE-2026-53488
9.4 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-01
- Last modified
- 2026-07-03
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.4 CRITICAL — CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10.
Affected configurations
• linuxfoundation containerd (>= 1.7.0 < 1.7.33)
• linuxfoundation containerd (>= 2.0.0 < 2.0.10)
• linuxfoundation containerd (>= 2.1.0 < 2.1.9)
• linuxfoundation containerd (>= 2.2.0 < 2.2.5)
• linuxfoundation containerd (>= 2.3.0 < 2.3.2)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/containerd/containerd/security/advisories/GHSA-xhf5-7wjv-pqxp Mitigation, Vendor Advisory