CVEvulnerability
CVE-2026-54163
4.7 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-07-17
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-113, CWE-79
Description
secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.
Related
References
- https://github.com/github/secure_headers/commit/286a79dea80c6a9be4ca93e0f284c923cf77e539 github.com
- https://github.com/github/secure_headers/releases/tag/v7.3.0 github.com
- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q github.com
- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q github.com