CVEvulnerability
CVE-2026-55514
7.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-06
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.1 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-617
Description
vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.
Affected configurations
• vllm vllm (>= 0.12.0 < 0.24.0)
Related
Weakness · CWE (1)
- CWE-617 Reachable Assertion weakness
References
- https://github.com/vllm-project/vllm/commit/470229c37efaf69c86e8bc97482b0b1ff7551c65 Patch
- https://github.com/vllm-project/vllm/pull/45252 Issue Tracking, Patch
- https://github.com/vllm-project/vllm/releases/tag/v0.24.0 Release Notes
- https://github.com/vllm-project/vllm/security/advisories/GHSA-33cg-gxv8-3p8g Vendor Advisory