CVEvulnerability
CVE-2026-55547
4.3 MEDIUM
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-08-28
- Last modified
- 2026-09-08
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-285, CWE-862
Description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits SystemPrivilege.ControlAccess checks from IamApi.listRoles, IamApi.getRole, and IamApi.listPrivileges in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java. Any authenticated account can call GET /api/roles, GET /api/roles/{name}, and GET /api/privileges to enumerate available system privileges and configured role mappings. The disclosure reveals security configuration that can support targeted privilege-escalation attempts. This issue is fixed in versions 5.12.8 and 5.13.2.
Related
References
- https://github.com/yamcs/yamcs/commit/c2aec1c242e656e48b52c7f87deea88183bb592d github.com
- https://github.com/yamcs/yamcs/commit/dcaec5f0b2f4231b8e313e94d79a937169c9e0ba github.com
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8 github.com
- https://github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2 github.com
- https://github.com/yamcs/yamcs/security/advisories/GHSA-cvw4-55pp-3hfq github.com
- https://github.com/yamcs/yamcs/security/advisories/GHSA-cvw4-55pp-3hfq github.com