CVEvulnerability

CVE-2026-55602

6.9 MEDIUM Published 2026-06-22 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-22
Last modified
2026-10-25
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.9 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Weaknesses
CWE-187, CWE-20

Description

http-proxy-middleware is node.js http-proxy middleware. From 0.16.0 until 2.0.10, 3.0.6, and 4.1.0, http-proxy-middleware documents router proxy-table entries as host, path, or host+path selectors, but the host+path implementation uses unanchored substring matching on attacker-controlled request metadata. As a result, a crafted Host header that is only a superstring match for a configured host+path key can still route a request to an unintended backend. This vulnerability is fixed in 2.0.10, 3.0.6, and 4.1.0.

Affected configurations

• chimurai http-proxy-middleware (>= 0.16.0 < 2.0.10) • chimurai http-proxy-middleware (>= 3.0.0 < 3.0.6) • chimurai http-proxy-middleware (>= 4.0.0 < 4.1.0)

Related

Weakness · CWE (2)

  • CWE-187 Partial String Comparison weakness
  • CWE-20 Improper Input Validation weakness

References