CVEvulnerability
CVE-2026-55697
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-25
- Last modified
- 2026-06-30
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-494, CWE-78, CWE-829
Description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.
Affected configurations
• pnpm pnpm (< 10.34.2)
• pnpm pnpm (>= 11.0.0 < 11.5.3)
Related
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x Exploit, Vendor Advisory
- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x Exploit, Vendor Advisory