CVEvulnerability
CVE-2026-55698
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-25
- Last modified
- 2026-06-30
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-345, CWE-494, CWE-829
Description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can persist package-manager bootstrap metadata in the first YAML document of pnpm-lock.yaml. Before the patch, direct pnpm execution trusted an already resolved packageManagerDependencies entry when the committed env lockfile contained matching pnpm and @pnpm/exe versions. A malicious repository could therefore commit package-manager lockfile package records and snapshots that bypassed fresh package-manager resolution, then cause pnpm to install and execute bytes selected by that committed lockfile state during automatic version switching. This vulnerability is fixed in 10.34.2 and 11.5.3.
Affected configurations
• pnpm pnpm (< 10.34.2)
• pnpm pnpm (>= 11.0.0 < 11.5.3)
Related
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-w466-c33r-3gjp Exploit, Vendor Advisory
- https://github.com/pnpm/pnpm/security/advisories/GHSA-w466-c33r-3gjp Exploit, Vendor Advisory