CVEvulnerability

CVE-2026-55956

6.5 MEDIUM Published 2026-06-29 Modified 2026-10-25 Official page ↗
Status
Analyzed
Published
2026-06-29
Last modified
2026-10-25
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-285

Description

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Affected configurations

• apache tomcat (< 9.0.119) • apache tomcat (>= 10.1.0 < 10.1.56) • apache tomcat (>= 11.0.0 < 11.0.23)

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References