CVEvulnerability
CVE-2026-55957
7.3 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-29
- Last modified
- 2026-10-25
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-304
Description
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.
Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Affected configurations
• apache tomcat (< 9.0.101)
• apache tomcat (>= 10.1.0 < 10.1.37)
• apache tomcat (>= 11.0.0 < 11.0.5)
Related
Weakness · CWE (1)
- CWE-304 Missing Critical Step in Authentication weakness
References
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/29/26 Third Party Advisory