CVEvulnerability
CVE-2026-56820
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-21
- Last modified
- 2026-07-30
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-295
Description
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and prior to 4.1.135.Final, `OcspClient` does not validate that the `CertificateID` in an OCSP response matches the requested `CertificateID`, which can lead to replay attack. `OcspClient.validateResponse` accepts a legitimately signed `GOOD` status response for an unrelated certificate issued by the same CA, allowing bypass of revocation checks for another certificate. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected configurations
• netty netty (< 4.1.136)
• netty netty (>= 4.2.0 < 4.2.16)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b Patch
- https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6 Patch
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final Release Notes
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final Release Notes
- https://github.com/netty/netty/security/advisories/GHSA-272m-gcwp-mpwg Exploit, Vendor Advisory