CVEvulnerability
CVE-2026-57817
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-08-06
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
The OpenID Connect Core 1.0 specification mandates that the RP MUST validate the `c_hash` parameter when operating in the Hybrid Flow. If an Apache CXF RP is integrated with a non-compliant or misconfigured Identity Provider (IdP) that omits the `c_hash`, the RP becomes vulnerable to Authorization Code Substitution/Injection attacks. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
Affected configurations
• apache cxf (< 3.6.12)
• apache cxf (>= 4.0.0 < 4.1.8)
• apache cxf (>= 4.2.0 < 4.2.3)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://lists.apache.org/thread/pj63c3pf7kkp1xhr53do704fwj3t3htn Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/06/19 www.openwall.com