CVEvulnerability

CVE-2026-59084

9.1 CRITICAL Published 2026-07-14 Modified 2026-10-24 Official page ↗
Status
Analyzed
Published
2026-07-14
Last modified
2026-10-24
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-1059

Description

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.

Affected configurations

• apache tomcat (>= 7.0.100 <= 7.0.109) • apache tomcat (>= 8.5.38 <= 8.5.100) • apache tomcat (>= 9.0.13 <= 9.0.119) • apache tomcat (>= 10.1.0 <= 10.1.56) • apache tomcat (>= 11.0.0 <= 11.0.23)

Related

Weakness · CWE (1)

  • CWE-1059 Insufficient Technical Documentation weakness

References