CVEvulnerability
CVE-2026-59195
8.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-06
- Last modified
- 2026-07-07
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L
- Weaknesses
- CWE-22
Description
pnpm is a package manager. Prior to 10.34.4 and 11.8.0, pnpm accepts package names from the env lockfile configDependencies section and uses those names directly when creating config dependency symlinks under node_modules/.pnpm-config. A malicious repository can commit a crafted pnpm-lock.yaml whose env-lockfile document contains a traversal-shaped config dependency name. During pnpm install, pnpm installs the config dependency and creates a symlink at a path derived from that name. This vulnerability is fixed in 10.34.4 and 11.8.0.
Affected configurations
• pnpm pnpm (< 10.34.4)
• pnpm pnpm (>= 11.0.0 < 11.8.0)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-qrv3-253h-g69c Exploit, Mitigation, Vendor Advisory
- https://github.com/pnpm/pnpm/security/advisories/GHSA-qrv3-253h-g69c Exploit, Mitigation, Vendor Advisory