CVEvulnerability
CVE-2026-59856
8.4 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-09
- Last modified
- 2026-07-14
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 8.4 HIGH — CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0736, the PHP omni-completion script in runtime/autoload/phpcomplete.vim interpolates a class or trait name, taken from the contents of the edited buffer, into a search() pattern that is run via win_execute() without escaping. A name containing a single quote can terminate the search() string argument early, and because the bar is honored as an Ex command separator, the remainder of the name is run as Ex commands; via the :! command this allows arbitrary operating-system command execution when a victim opens a crafted PHP file and invokes omni-completion. This issue is fixed in version 9.2.0736.
Affected configurations
• vim vim (< 9.2.0736)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/vim/vim/commit/43afc581a37a35762dd0ef292f038b9dc5680a24 Patch
- https://github.com/vim/vim/security/advisories/GHSA-fh26-8f79-wj97 Exploit, Patch, Vendor Advisory