CVEvulnerability
CVE-2026-59878
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-28
- Last modified
- 2026-08-05
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All.
A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections.
This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8.
Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Affected configurations
• apache activemq (< 5.19.9)
• apache activemq (>= 6.0.0 < 6.2.8)
• apache activemq all (< 5.19.9)
• apache activemq all (>= 6.0.0 < 6.2.8)
• apache activemq amqp (< 5.19.9)
• apache activemq amqp (>= 6.0.0 < 6.2.8)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://lists.apache.org/thread/dnyx4d2oldshcj4lthso7b53y4bqmjvn Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/27/7 Mailing List, Third Party Advisory