CVEvulnerability
CVE-2026-59948
7.0 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-07-08
- Last modified
- 2026-07-10
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22, CWE-787
Description
Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.
Related
References
- https://github.com/composer/composer/commit/502c6c4f699802d9cf464728b3e8a95674f919a0 github.com
- https://github.com/composer/composer/commit/c50b1efd13ebd73f6dca19b31424c5a02bf93cc1 github.com
- https://github.com/composer/composer/releases/tag/2.10.2 github.com
- https://github.com/composer/composer/releases/tag/2.2.29 github.com
- https://github.com/composer/composer/security/advisories/GHSA-499r-g7pc-vmp9 github.com