CVEvulnerability

CVE-2026-59978

7.5 HIGH EPSS 0.65% Published 2026-10-30 Modified 2026-10-30 Official page ↗

Exploitation and prioritisation

EPSS
0.65% chance of exploitation in the next 30 days · in the top 49.0% of all CVEs (2026-11-03)
EU Vulnerability Database
EUVD-2026-114329

Affected packages

EcosystemPackageVulnerableFixed inAdvisory
Packagistadminneo-org/adminneo>= 4.6.2, < 5.5.05.5.0GHSA-jm85-8cpp-9cjc
Status
Deferred
Published
2026-10-30
Last modified
2026-10-30
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20

Description

AdminNeo is a full-featured database management tool written in PHP. From 4.6.2 until 5.5.0, the unauthenticated `?script=version` endpoint accepts POST data without origin, CSRF or parameter-type validation. A `version[]` parameter becomes a PHP array that `bootstrap.inc.php` serializes into the shared `adminneo.version` cache. On later page loads, `design.inc.php` passes that cached value to `cookie()` and `rawurlencode()`, causing a `TypeError` rather than encoding a version string. A remote attacker can make the instance return HTTP 500 to all users for the cache's twenty-four-hour lifetime or until the poisoned cache is removed. Exploitation requires the web server to be able to write that shared cache; making it unwritable is an interim workaround. The issue retains the underlying type-validation defect reported previously in Adminer despite changes to AdminNeo's version-checking flow. This issue is fixed in version 5.5.0.

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

Referenced by GitHub Advisory · alias (1)

  • GHSA-jm85-8cpp-9cjc AdminNeo: version-cache array injection causes persistent denial of service advisory · Packagist

References