CVEvulnerability
CVE-2026-6107
5.1 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-04-12
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.1 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79, CWE-94
Description
A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Related
References
- https://github.com/1Panel-dev/MaxKB/ github.com
- https://github.com/1Panel-dev/MaxKB/commit/026a2d623e2aa5efa67c4834651e79d5d7cab1da github.com
- https://github.com/1Panel-dev/MaxKB/pull/4919 github.com
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.8.0 github.com
- https://github.com/AnalogyC0de/public_exp/issues/24 github.com
- https://vuldb.com/submit/782263 vuldb.com
- https://vuldb.com/vuln/356966 vuldb.com
- https://vuldb.com/vuln/356966/cti vuldb.com