CVEvulnerability

CVE-2026-61846

6.3 MEDIUM EPSS 0.49% Published 2026-10-30 Modified 2026-10-30 Official page ↗

Exploitation and prioritisation

EPSS
0.49% chance of exploitation in the next 30 days · in the top 58.1% of all CVEs (2026-11-03)
EU Vulnerability Database
EUVD-2026-114322

Affected packages

EcosystemPackageVulnerableFixed inAdvisory
RubyGemscrass< 1.0.71.0.7GHSA-6jxj-px6v-747w
Status
Deferred
Published
2026-10-30
Last modified
2026-10-30
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weaknesses
CWE-674

Description

Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses `CSS simple blocks and functions` without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises `SystemStackError`: stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.

Related

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

Referenced by GitHub Advisory · alias (1)

  • GHSA-6jxj-px6v-747w Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage advisory · RubyGems

References