CVEvulnerability

CVE-2026-62440

9.1 CRITICAL Published 2026-08-21 Modified 2026-10-16 Official page ↗
Status
Analyzed
Published
2026-08-21
Last modified
2026-10-16
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284

Description

Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.

Affected configurations

• apache cloudstack (>= 4.21.0.0 < 4.22.1.1)

Related

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References