CVEvulnerability

CVE-2026-65182

9.1 CRITICAL Published 2026-08-25 Modified 2026-08-27 Official page ↗
Status
Analyzed
Published
2026-08-25
Last modified
2026-08-27
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284, CWE-863

Description

Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.

Affected configurations

• apache tomcat (>= 7.0.0 <= 7.0.109) • apache tomcat (>= 8.5.0 < 9.0.121) • apache tomcat (>= 10.1.0 < 10.1.58) • apache tomcat (>= 11.0.0 < 11.0.25)

Related

Weakness · CWE (2)

  • CWE-284 Improper Access Control weakness
  • CWE-863 Incorrect Authorization weakness

References