CVEvulnerability
CVE-2026-66142
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-24
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
Apache Neethi is vulnerable to uncontrolled recursion when parsing policies that lack policy Ids or with deeply nested structures, which may lead to a denial of service attack when parsing policies due to runtime memory exhaustion. Users are recommended to upgrade to version 3.2.3, which fixes this issue.
Affected configurations
• apache neethi (< 3.2.3)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://lists.apache.org/thread/fomwtwt4pzzhxn4fyn3skykto913vfzt Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/24/8 Mailing List, Third Party Advisory