CVEvulnerability

CVE-2026-66422

8.1 HIGH Published 2026-08-25 Modified 2026-08-27 Official page ↗
Status
Analyzed
Published
2026-08-25
Last modified
2026-08-27
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-285

Description

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected configurations

• apache tomcat (>= 7.0.97 <= 7.0.109) • apache tomcat (>= 8.5.46 < 9.0.121) • apache tomcat (>= 10.1.0 < 10.1.58) • apache tomcat (>= 11.0.0 < 11.0.25)

Related

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References