CVEvulnerability
CVE-2026-68939
2.0 LOW
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-08-18
- Last modified
- 2026-09-18
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.0 LOW — CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-155, CWE-78, CWE-88
Description
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
Related
References
- https://github.com/pyenv/pyenv/commit/95df7dbc7b34595b47c9b922de198547effda819 github.com
- https://github.com/pyenv/pyenv/releases/tag/v2.8.0 github.com
- https://github.com/pyenv/pyenv/security/advisories/GHSA-g478-f579-9vp9 github.com
- https://github.com/pyenv/pyenv/security/advisories/GHSA-g478-f579-9vp9 github.com