CVEvulnerability
CVE-2026-69152
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-03
- Last modified
- 2026-10-23
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400, CWE-770
Description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.
Affected configurations
• juliangruber brace-expansion (< 1.1.18)
• juliangruber brace-expansion (>= 2.0.0 < 2.1.4)
• juliangruber brace-expansion (>= 3.0.0 < 3.0.6)
• juliangruber brace-expansion (>= 4.0.0 < 5.0.9)
Related
References
- https://github.com/juliangruber/brace-expansion/commit/139d015104e71433ad52a41d19467c48ecbb2c7d Patch
- https://github.com/juliangruber/brace-expansion/commit/1e30c930238d7162802d88a94189182def178dac Patch
- https://github.com/juliangruber/brace-expansion/commit/688a99eeaab02627c2b89ba8ba4821fecfa659cf Patch
- https://github.com/juliangruber/brace-expansion/commit/cb4b9e47cc2ec777c14b2b4492fb431a56f6a031 Patch
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-rgw5-rvv9-x895 Exploit, Mitigation, Vendor Advisory
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-rgw5-rvv9-x895 Exploit, Mitigation, Vendor Advisory