CVEvulnerability
CVE-2026-69254
9.4 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-04
- Last modified
- 2026-10-23
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.4 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, executeJavaScriptCode() accepted caller-provided nodeVMOptions and merged them over the default NodeVM security settings in packages/components/src/utils.ts. An authenticated attacker reaching packages/server/src/routes/node-custom-functions/index.ts could run a custom function that imported flowise-components/dist/src/utils.js, called executeJavaScriptCode() again with nodeVMOptions.require.builtin set to allow all built-in modules, and then required child_process to execute arbitrary system commands as root on the Flowise server. This issue is fixed in version 3.1.3.
Affected configurations
• flowiseai flowise (< 3.1.3)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/FlowiseAI/Flowise/commit/3086cb7e323bb96c5a581d3232ef975b0d92183d Patch
- https://github.com/FlowiseAI/Flowise/pull/6306 Issue Tracking, Patch
- https://github.com/FlowiseAI/Flowise/releases/tag/[email protected] Patch, Release Notes
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-3769-jgqc-cxm7 Exploit, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-3769-jgqc-cxm7 Exploit, Vendor Advisory