CVEvulnerability

CVE-2026-71290

9.1 CRITICAL Published 2026-08-11 Modified 2026-10-24 Official page ↗
Status
Analyzed
Published
2026-08-11
Last modified
2026-10-24
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-295

Description

Improper TLS hostname verification vulnerability in Apache HttpComponents Client 5.4 or newer. HostnameVerificationPolicy#BUILTIN setting has no effect when used with the async version of HttpClient. An attacker that can intercept and modify traffic between the client and the server can impersonate the server by presenting a valid certificate for a different domain.  Please note the classic version of HttpClient is not affected by this vulnerability.  Affected users are recommended to upgrade to at least version 5.6.4, which fixes the issue.

Affected configurations

• apache httpclient (>= 5.4 < 5.6.4)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References