CVEvulnerability

CVE-2026-71558

9.8 CRITICAL Published 2026-08-07 Modified 2026-10-24 Official page ↗
Status
Analyzed
Published
2026-08-07
Last modified
2026-10-24
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502, CWE-843

Description

Heap type confusion vulnerability in Apache Fory C++ deserialization. This issue affects Apache Fory C++ versions from 0.14.0 before 1.5.0. A crafted input payload can bypass type compatibility checks during polymorphic smart-pointer deserialization, causing an object of an incompatible type to be treated as the declared base type. This may result in undefined behavior and potentially lead to denial of service or arbitrary code execution. Users are recommended to upgrade to Apache Fory 1.5.0, which fixes this issue. Applications not using Apache Fory C++ polymorphic smart-pointer deserialization are not affected.

Affected configurations

• apache fory (>= 0.14.0 < 1.5.0)

Related

Weakness · CWE (2)

  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-843 Access of Resource Using Incompatible Type weakness

References