CVEvulnerability
CVE-2026-73070
6.8 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-11
- Last modified
- 2026-10-29
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.8 MEDIUM — CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-121
Description
Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.
Affected configurations
• vim vim (>= 9.2.0512 < 9.2.0842)
Related
Weakness · CWE (1)
- CWE-121 Stack-based Buffer Overflow weakness
References
- https://github.com/vim/vim/commit/5598618b2daf8e36b3bf0251caaefcf0bf8e85e4 Patch
- https://github.com/vim/vim/releases/tag/v9.2.0842 Product, Release Notes
- https://github.com/vim/vim/security/advisories/GHSA-49m8-wwxj-mr69 Patch, Vendor Advisory