CVEvulnerability
CVE-2026-73075
4.6 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-11
- Last modified
- 2026-10-06
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 4.6 MEDIUM — CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 3.9 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-124, CWE-125
Description
Vim is an open source, command line text editor. From 9.2.0469 until 9.2.0843, popup_mark_opacity_zindex() in src/popupwin.c can use a negative w_winrow for a text-property-anchored popup with clipwindow and opacity, indexing before the screen array instead of accounting for w_popup_topoff and causing an out-of-bounds read and conditional write. This issue is fixed in version 9.2.0843.
Affected configurations
• vim vim (>= 9.2.0469 < 9.2.0843)
Related
References
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4 Patch, Vendor Advisory
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4 Patch, Vendor Advisory
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4 Patch, Vendor Advisory
- https://github.com/vim/vim/security/advisories/GHSA-pmvp-6rcj-98p4 Patch, Vendor Advisory