CVEvulnerability

CVE-2026-73180

6.8 MEDIUM Published 2026-08-25 Modified 2026-08-27 Official page ↗
Status
Analyzed
Published
2026-08-25
Last modified
2026-08-27
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-613

Description

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected configurations

• apache tomcat (>= 7.0.43 <= 7.0.109) • apache tomcat (>= 8.5.0 < 9.0.121) • apache tomcat (>= 10.1.0 < 10.1.58) • apache tomcat (>= 11.0.0 < 11.0.25)

Related

Weakness · not in database (1)

References