CVEvulnerability
CVE-2026-73256
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-20
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-444
Description
Mongoose is an embedded web server and network library. Prior to 7.22, a remote unauthenticated attacker can exploit an HTTP/1.0 reverse-proxy deployment by sending a request with Transfer-Encoding: chunked and conflicting framing. The http_cb() function in src/http.c tests hm.proto.len with an impossible greater-than-eight condition even though mg_http_parse() requires an eight-byte protocol string, so is_http_1_0 is never set. Mongoose consequently processes chunked encoding that an HTTP/1.0 proxy can ignore, enabling request smuggling and unauthorized access or state changes. This issue is fixed in version 7.22.
Affected configurations
• cesanta mongoose (< 7.22)
Related
Weakness · CWE (1)
- CWE-444 Inconsistent Interpretation of HTTP Requests weakness
References
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71 Patch
- https://github.com/cesanta/mongoose/pull/3611 Issue Tracking, Patch
- https://github.com/cesanta/mongoose/releases/tag/7.22 Release Notes
- https://github.com/cesanta/mongoose/security/advisories/GHSA-mgp5-rjrv-h5j3 Exploit, Vendor Advisory