CVEvulnerability
CVE-2026-73258
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-20
- Last modified
- 2026-10-18
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-697
Description
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.
Affected configurations
• cesanta mongoose (< 7.22)
Related
Weakness · CWE (1)
- CWE-697 Incorrect Comparison weakness
References
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71 Patch
- https://github.com/cesanta/mongoose/pull/3611 Issue Tracking, Patch
- https://github.com/cesanta/mongoose/releases/tag/7.22 Release Notes
- https://github.com/cesanta/mongoose/security/advisories/GHSA-cc55-8v3r-59p8 Exploit, Vendor Advisory
- https://github.com/cesanta/mongoose/security/advisories/GHSA-cc55-8v3r-59p8 Exploit, Vendor Advisory