CVEvulnerability
CVE-2026-73263
9.9 CRITICAL
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-08-12
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-78
Description
Prowler is a cloud security platform. Prior to 5.36.0, the Kubernetes provider connection test accepted kubeconfig_content containing a legacy gcp auth-provider with config.cmd-path and config.cmd-args because kubeconfig_contains_exec_auth in api/src/backend/api/v1/serializers.py checked only exec blocks, and POST /api/v1/providers/{id}/connection loaded it through config.load_kube_config_from_dict in prowler/providers/kubernetes/kubernetes_provider.py, causing kubernetes-python CommandTokenSource.token to run the attacker-supplied command through subprocess.Popen on the shared worker. This issue is fixed in version 5.36.0.
Related
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://github.com/prowler-cloud/prowler/commit/0b782fcb8c24ece7bd38deede2b8f13d8583e39c github.com
- https://github.com/prowler-cloud/prowler/pull/12091 github.com
- https://github.com/prowler-cloud/prowler/releases/tag/5.36.0 github.com
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j github.com
- https://github.com/prowler-cloud/prowler/security/advisories/GHSA-ccqh-6cjc-wp4j github.com