CVEvulnerability

CVE-2026-73633

7.5 HIGH Published 2026-08-14 Modified 2026-08-18 Official page ↗
Status
Analyzed
Published
2026-08-14
Last modified
2026-08-18
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400

Description

Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts. When an application is configured to populate actions from a JSON request body, the plugin reads that body into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. The plugin's configurable JSON input length limit does not bound this read. The JSON plugin is an optional component; applications that do not use it, or use it without enabling JSON request-body handling, are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Affected configurations

• apache struts (>= 2.1.8 <= 2.3.37) • apache struts (>= 2.5.0 <= 2.5.33) • apache struts (>= 6.0.0 < 6.11.0) • apache struts (>= 7.0.0 < 7.3.0)

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References