CVEvulnerability
CVE-2026-74848
7.0 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-27
- Last modified
- 2026-08-31
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.0 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-444
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX.
An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes.
This issue affects Apache APISIX: from 2.12.0 through 3.17.0.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected configurations
• apache apisix (>= 2.12.0 < 3.18.0)
Related
Weakness · CWE (1)
- CWE-444 Inconsistent Interpretation of HTTP Requests weakness
References
- https://lists.apache.org/thread/xdgpszmw8dw4wvmfxy043d83m150kx3n Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/26/12 Mailing List, Third Party Advisory