CVEvulnerability
CVE-2026-75857
7.3 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-08-18
- Last modified
- 2026-10-22
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.3 HIGH — CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
CodeWhale versions >= 0.8.41 and < 0.8.64 contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in 0.8.64.
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381 github.com
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r github.com
- https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact www.vulncheck.com
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r github.com