CVEvulnerability

CVE-2026-75975

7.5 HIGH Published 2026-08-24 Modified 2026-10-14 Official page ↗
Status
Analyzed
Published
2026-08-24
Last modified
2026-10-14
Assigner
ce714d77-add3-4f53-aff5-83d477b104bb
CVSS 3.1 (ce714d77-add3-4f53-aff5-83d477b104bb)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20, CWE-918

Description

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

Affected configurations

• openjsf fast-uri (>= 2.3.1 < 2.4.5) • openjsf fast-uri (>= 3.0.0 < 3.1.6) • openjsf fast-uri (>= 4.0.0 < 4.1.3)

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-918 Server-Side Request Forgery weakness

References