CVEvulnerability
CVE-2026-76572
5.1 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-08-19
- Last modified
- 2026-08-20
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.1 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- CVSS 2.0 ([email protected])
- 5.8 MEDIUM — AV:N/AC:L/Au:M/C:P/I:P/A:P
- Weaknesses
- CWE-610, CWE-611
Description
A vulnerability was detected in pkp pkp-lib up to 3.3.0-22/3.4.0-10/3.5.0-4. The affected element is the function _transformPHP of the file classes/xslt/XSLTransformer.php. The manipulation results in xml external entity reference. The attack can be executed remotely. Upgrading to version 3.3.0-23, 3.4.0-11 and 3.5.0-5 is sufficient to fix this issue. The patch is identified as 78c699370ea43ae2784e1c4ace7c947d207f2b47. Upgrading the affected component is advised.
Related
References
- https://github.com/pkp/pkp-lib/ github.com
- https://github.com/pkp/pkp-lib/commit/78c699370ea43ae2784e1c4ace7c947d207f2b47 github.com
- https://github.com/pkp/pkp-lib/issues/12977 github.com
- https://github.com/pkp/pkp-lib/releases/tag/3_5_0-5 github.com
- https://vuldb.com/cve/CVE-2026-76572 vuldb.com
- https://vuldb.com/submit/878359 vuldb.com
- https://vuldb.com/vuln/393037 vuldb.com
- https://vuldb.com/vuln/393037/cti vuldb.com