CVEvulnerability

CVE-2026-76851

7.7 HIGH Published 2026-09-01 Modified 2026-09-08 Official page ↗
Status
Analyzed
Published
2026-09-01
Last modified
2026-09-08
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918

Description

A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed remote code execution on the instance. Insufficient network isolation allowed malicious pre-receive hook code to impersonate an internal service and redirect trusted internal requests to a privileged service, leading to elevated code execution. Exploitation required pre-receive hook networking to be enabled and either site administrator privileges or write access to a repository containing a configured pre-receive hook. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.20, 3.18.14, 3.19.11, 3.20.7, and 3.21.5. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.17.20) • github enterprise server (>= 3.18.0 < 3.18.14) • github enterprise server (>= 3.19.0 < 3.19.11) • github enterprise server (>= 3.20.0 < 3.20.7) • github enterprise server (>= 3.21.0 < 3.21.5)

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References