CVEvulnerability
CVE-2026-77147
6.5 MEDIUM
Official page ↗
- Status
- Deferred
- Published
- 2026-09-14
- Last modified
- 2026-09-14
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope.
An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://lists.apache.org/thread/qr464o2lyj3rxp8b0q25ssn0qwjxyrgz lists.apache.org
- http://www.openwall.com/lists/oss-security/2026/09/14/15 www.openwall.com