CVEvulnerability
CVE-2026-77405
9.4 CRITICAL
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-09-16
- Last modified
- 2026-09-24
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.4 CRITICAL — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- Weaknesses
- CWE-326
Description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Related
Weakness · CWE (1)
- CWE-326 Inadequate Encryption Strength weakness
References
- https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e github.com
- https://github.com/rabbitmq/amqp091-go/pull/355 github.com
- https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0 github.com
- https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h github.com