CVEvulnerability

CVE-2026-8034

7.9 HIGH Published 2026-05-07 Modified 2026-10-26 Official page ↗
Status
Analyzed
Published
2026-05-07
Last modified
2026-10-26
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.9 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-436, CWE-918

Description

A server-side request forgery (SSRF) vulnerability was identified in the GitHub Enterprise Server notebook viewer that allowed an attacker to access internal services by exploiting URL parser confusion between the validation layer and the HTTP request library. The hostname validation used a different URL parser than the request library, enabling a crafted URL to pass validation while directing the request to an unintended host. Exploitation required network access to the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.16.18, 3.17.15, 3.18.9, 3.19.6, and 3.20.2. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.16.18) • github enterprise server (>= 3.17.0 < 3.17.15) • github enterprise server (>= 3.18.0 < 3.18.9) • github enterprise server (>= 3.19.0 < 3.19.6) • github enterprise server (>= 3.20.0 < 3.20.2)

Related

Weakness · CWE (2)

  • CWE-436 Interpretation Conflict weakness
  • CWE-918 Server-Side Request Forgery weakness

References