CVEvulnerability

CVE-2026-80352

9.8 CRITICAL Published 2026-09-10 Modified 2026-09-14 Official page ↗
Status
Analyzed
Published
2026-09-10
Last modified
2026-09-14
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Camel K. A YAML injection vulnerability in custom resource configuration allows an authorized CR author to inject arbitrary Kubernetes objects, potentially enabling unauthorized resource creation with the privileges of the operator. This issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2. Users are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.

Affected configurations

• apache camel (>= 2.0.0 < 2.9.3) • apache camel (>= 2.10.0 < 2.10.2)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References