CVEvulnerability
CVE-2026-82333
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-28
- Last modified
- 2026-09-02
- Assigner
- ce714d77-add3-4f53-aff5-83d477b104bb
- CVSS 3.1 (ce714d77-add3-4f53-aff5-83d477b104bb)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.
Affected configurations
• expressjs multer (< 2.3.0)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://cna.openjsf.org/security-advisories.html Vendor Advisory
- https://github.com/expressjs/multer/security/advisories/GHSA-535w-7cp7-47q4 Vendor Advisory